Last modified: 2012-07-30 20:30:40 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 14635 - Images listed in database have missing files
Images listed in database have missing files
Status: RESOLVED WORKSFORME
Product: Wikimedia
Classification: Unclassified
General/Unknown (Other open bugs)
unspecified
All All
: Low critical with 1 vote (vote)
: ---
Assigned To: Nobody - You can work on this!
http://en.wikipedia.org/wiki/Image:Ni...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-24 22:18 UTC by OverlordQ
Modified: 2012-07-30 20:30 UTC (History)
3 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description OverlordQ 2008-06-24 22:18:27 UTC
URL goes to one example.

Compiled lists of those (that I could find) on enwiki and commonswiki:

http://toolserver.org/~overlordq/404commons_path.txt
http://toolserver.org/~overlordq/404images_path.txt
Comment 1 OverlordQ 2008-06-25 21:00:53 UTC
Gmaxwell was kind enough to restore 4 of these images from backups he had, but these four images triggered another bug.

As talked about in #wikimedia-tech yesterday there were images that were sharing the sha1 hash of 'phoiac9h4m842xq45sp7s6u21eteeq1'  This was attributed to them being 'old' from before images were sha1'd.

However, all 4 of the images Gmaxwell uploaded have the same hash of phoiac9h4m842xq45sp7s6u21eteeq1. Don't know if this is related or not, but action=purge doesnt seem to be fixing the problem as it did with the previous set of images.
Comment 2 Roan Kattouw 2009-01-17 21:44:47 UTC
(In reply to comment #1)
> Gmaxwell was kind enough to restore 4 of these images from backups he had, but
> these four images triggered another bug.
> 
> As talked about in #wikimedia-tech yesterday there were images that were
> sharing the sha1 hash of 'phoiac9h4m842xq45sp7s6u21eteeq1'  This was attributed
> to them being 'old' from before images were sha1'd.
> 
> However, all 4 of the images Gmaxwell uploaded have the same hash of
> phoiac9h4m842xq45sp7s6u21eteeq1. Don't know if this is related or not, but
> action=purge doesnt seem to be fixing the problem as it did with the previous
> set of images.
> 

See also bug 17051. phoiac9h4m842xq45sp7s6u21eteeq1 is the hash of the empty string, which suggests some breakage in the SHA-1 hashing code. This seems to be fixed, however, as I just re-uploaded [[commons:File:5von10.jpg]] (which previously had phoiac9h4m842xq45sp7s6u21eteeq1 as hash) over itself which caused it to get the right hash (or at least a hash different from phoiac9h4m842xq45sp7s6u21eteeq1). There are also images (and old revisions of images) with img_sha1='' out there, which is probably a symptom of yet another former bug.

Useful lists:
Last 5 revisions of [[commons:File:5von10.jpg]]: http://commons.wikimedia.org/w/api.php?action=query&titles=File:5von10.png&gdflimit=max&prop=imageinfo&iiprop=sha1|user|comment|timestamp&iilimit=5
List of files with the same hash as [[commons:File:Amphipodredkils.jpg]]: http://commons.wikimedia.org/w/api.php?action=query&titles=File:Amphipodredkils.jpg&generator=duplicatefiles&gdflimit=max&prop=imageinfo&iiprop=sha1
Comment 3 matanya 2012-07-30 20:30:40 UTC
seems to be fixed.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links