Last modified: 2008-08-16 21:45:30 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 14463 - Can't transwiki page if target exists
Can't transwiki page if target exists
Status: RESOLVED INVALID
Product: MediaWiki
Classification: Unclassified
Special pages (Other open bugs)
unspecified
All All
: Normal normal with 1 vote (vote)
: ---
Assigned To: Nobody - You can work on this!
: crosswiki
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-07 15:46 UTC by Danny B.
Modified: 2008-08-16 21:45 UTC (History)
1 user (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Danny B. 2008-06-07 15:46:31 UTC
It used to be possible to import the page when the page with the same name existed on target project, so one could import missing history if somebody just copypasted the source project last revision to target project. This is no longer possible but it should to fulfill the GFDL.
Comment 1 Brion Vibber 2008-06-09 19:06:15 UTC
Should still work fine. What exactly do you see when you try?

Please provide:
* exact steps to reproduce (which wikis are you using, what pages are you trying, which buttons are you pushing)

* exact error messages, if any, or other output
Comment 2 Danny B. 2008-06-09 20:21:50 UTC
Trying to transwiki Šablona:Wikimedia Foundation from w:cs: [1] to wikt:cs: [2] (to bring the missing history). The wikt:cs: one has been created as copy paste from w:cs:.

Copy all history versions for this page checked
Transfer pages into namespace: all

Pushing Import button.

Red error message on the top: Import failed: Could not open import file

Tried both Šablona: and Template: (both are ns:template names), none worked.

[1] http://cs.wikipedia.org/wiki/%C5%A0ablona:Wikimedia_Foundation
[2] http://cs.wiktionary.org/wiki/%C5%A0ablona:Wikimedia_Foundation

P. S.: After trying to transwiki this template I've tried two articles and they've been transwikied without any problem.
Comment 3 Brion Vibber 2008-06-09 20:50:01 UTC
Ok, that was due to a downed text storage database slave. Requests for particular revisions stored on that cluster would take an extra long time due to attempts to contact the downed server before moving on to a live one.

The export request was fulfilled, but took several seconds, and the import client timed out before then.

With the dead one out of rotation, the export is quick again and import should succeed.

Note that this is a bit of a temporary hackaround; next time there's a bad server it'll do the same thing unless a better failover that doesn't take so long is put in place.
Comment 4 Siebrand Mazeland 2008-08-16 21:45:30 UTC
Given comment 3, I am closing this issue as INVALID, as the issue was not with special pages, but with a database server in a wiki environment. Nothing broken in MediaWiki.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links