Last modified: 2008-07-17 13:07:13 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 14348 - Special:ListUsers returning without results. Empty GET parameter.
Special:ListUsers returning without results. Empty GET parameter.
Status: RESOLVED WORKSFORME
Product: MediaWiki
Classification: Unclassified
Special pages (Other open bugs)
unspecified
All All
: Normal normal (vote)
: ---
Assigned To: Nobody - You can work on this!
http://en.wikipedia.org/wiki/Special:...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-30 18:45 UTC by Florian Sidler
Modified: 2008-07-17 13:07 UTC (History)
0 users

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Florian Sidler 2008-05-30 18:45:09 UTC
I just went to look for something on Special:ListUsers, and after a few clicks got an empty list when i tried to display all members of a certain group. Looking at it a little closer, i noticed that after entering a name and starting the search, and then blanking the input field and searching again, i got no results. The "username" parameter in the URIs query string is empty (http://en.wikipedia.org/w/index.php?title=Special%3AListUsers&username=&group=sysop&limit=50). Oddly, it seems to randomly be working and not working, changing randomly with every click on the OK button.
Comment 1 Florian Sidler 2008-05-30 18:50:55 UTC
Also made a video of it, in case you don't believe me. :-P
http://shaxxer.org/~tws/stuff/ztemp/listusers.avi
Comment 2 Brion Vibber 2008-05-30 21:20:21 UTC
Seems ok at present; may have been a temporary glitch due to the borked DB server that was in for a bit.

Yep. Getting this worked out; user_group fields need to be converted to varbinary before the 5.0 migration or the padding breaks.
Comment 3 Florian Sidler 2008-05-31 06:28:23 UTC
Confirmed, works fine now.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links