Last modified: 2008-06-10 14:54:41 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 14309 - Unified Login: Accounts were attached yesterday, but today they are unattached
Unified Login: Accounts were attached yesterday, but today they are unattached
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
User login and signup (Other open bugs)
unspecified
All All
: Normal major (vote)
: ---
Assigned To: Tim Starling
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-28 12:53 UTC by jeroenvrp
Modified: 2008-06-10 14:54 UTC (History)
2 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description jeroenvrp 2008-05-28 12:53:02 UTC
Yesterday I had a lot of (300+) accounts attached to my global account "Jeroen" (home wiki nl.wikipedia). Those were automatically created yesterday evening.

Today my global account was somehow deleted, so I recreated it. Afterwards all those automatically created accounts appeared unattached. Using my global password to unattach them doesn't work. There were 29 attached. They were the same that were attached yesterday afternoon, before I automatically created all those accounts yesterday evening.

I also can't log in to all those unattached Jeroen-accounts. I can "unlock" when sending my self a temporary password. 

So it seemed that a lot of Jeroen-accounts have a corrupt password (not all; there a 7 accounts that are not mine at all (yet)). E-mails are set correctly (cause I can sent a temp. password). I have "unlocked" 11 of them, but there are now 341 (348-7) accounts that are not accessible with my global account password.

Please investigate?
Comment 1 Brion Vibber 2008-05-28 17:36:34 UTC
According to log...

http://meta.wikimedia.org/w/index.php?title=Special%3ALog&type=globalauth&user=&page=User%3AJeroen%40global&year=&month=-1

    * 01:21, 28 May 2008 Rdsmith4 (Talk | contribs | block) deleted global account "User:Jeroen@global" ‎ (rename on en.wikipedia)
    * 20:27, 27 May 2008 Majorly (Talk | contribs | block) deleted global account "User:Jeroen@global" ‎ (attempting to rename for meta...)
Comment 2 Brion Vibber 2008-05-28 17:42:58 UTC
The passwords may have been corrupted by a (recently-fixed) bug in CentralAuth...

Originally a steward could fix this for you by manually reattaching the remaining accounts, but this seems to have been dropped from Special:CentralAuth.

Probably need to get it put back...
Comment 3 Titoxd 2008-06-04 06:40:56 UTC
Is this the same thing as Bug 14330 ?
Comment 4 Tim Starling 2008-06-05 13:29:21 UTC
I'll copy the passwords across once r35923 is live, then you'll be able to remerge them.
Comment 5 jeroenvrp 2008-06-06 00:24:01 UTC
Unfortunately it still does not work.

Now I read in my preferences that all is right and my previous listed unattached projects are gone. That seems ok, but now I can't remerge my unattached projects anymore. I also can't still login like before (only using the password reminder like before); so the passwords still seems to be corrupt.

It is also strange that the few projects where I am not the owner of username Jeroen (e.g. commons) are also not listed anymore.

nl.wikipedia uses now r35959 (thats newer as r35923 I presume).
Comment 6 Brion Vibber 2008-06-06 00:29:51 UTC
The password update hasn't been done yet.
Comment 7 Tim Starling 2008-06-06 06:35:45 UTC
Should be done now.
Comment 8 jeroenvrp 2008-06-06 13:36:58 UTC
Ok that works. Thanks. Unfortunately I can't see my unattached projects anymore, but the major problem, the corrupted passwords, is solved.
Comment 9 jeroenvrp 2008-06-10 14:54:41 UTC
Ok now everything is solved. Great job! Thanks!

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links