Last modified: 2010-05-15 16:03:14 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 14047 - mediawiki install doesn't data base prefix
mediawiki install doesn't data base prefix
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
Installer (Other open bugs)
1.13.x
All All
: Normal critical (vote)
: ---
Assigned To: Brion Vibber
:
Depends on:
Blocks: sqlite
  Show dependency treegraph
 
Reported: 2008-05-08 17:35 UTC by Bertrand GRONDIN
Modified: 2010-05-15 16:03 UTC (History)
0 users

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Bertrand GRONDIN 2008-05-08 17:35:10 UTC
The new mediawiki installer doesn't show the database prefix option. For users who' want to update their own wiki, it's impossible by /config/index.php.

Installer creates, now, new tables without prefix.
Comment 1 Brion Vibber 2008-05-08 20:07:07 UTC
This was broken by the recent changes to add SQLite support; the SQLite config bit wasn't done quite right, resulting in the JS goodies hiding MySQL but not re-showing it.

Fixed in r34457, along with improving the SQLite installer support and the generated LocalSettings.php.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links