Last modified: 2012-04-12 13:55:13 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 14005 - editing section 0 of an existing but empty page gives no such section error
editing section 0 of an existing but empty page gives no such section error
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
Page editing (Other open bugs)
1.16.x
All All
: Normal normal with 1 vote (vote)
: ---
Assigned To: Nobody - You can work on this!
: patch, patch-reviewed
: 26627 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-06 23:34 UTC by CBM
Modified: 2012-04-12 13:55 UTC (History)
6 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
Patch v1 (489 bytes, patch)
2011-03-19 22:59 UTC, Jarry1250
Details

Description CBM 2008-05-06 23:34:32 UTC
If you try to edit section 0 of an empty page, a "no such section" error is returned.
Comment 1 Siebrand Mazeland 2008-08-17 22:55:14 UTC
Tested with 1.14-svn (r39529). WORKSFORME. Sample URL:

http://translatewiki.net/w/i.php?title=User:Siebrand/thispagedoesnotexist&action=edit&section=0
Comment 2 CBM 2008-08-18 00:20:59 UTC
I'm sorry; my report was slightly unclear. The error is with pages that do exist but have 0 bytes of content. In such a page, the entire page (which  has no content) is section 0, so editing section 0 should work. However, the 'nosuchsectiontext' error message is displayed instead. I have just tested this again on enwiki. 

http://en.wikipedia.org/w/index.php?title=User:CBM/Empty&action=edit&section=0
Comment 3 db [inactive,noenotif] 2011-01-10 17:09:11 UTC
*** Bug 26627 has been marked as a duplicate of this bug. ***
Comment 4 Mark A. Hershberger 2011-01-22 01:54:36 UTC
Reproduced on prototype: http://prototype.wikimedia.org/rc-en/index.php?title=Empty_Page&action=edit&section=0
Comment 5 Siebrand Mazeland 2011-01-22 12:33:44 UTC
Strange. Comment 1 is also still true.
Comment 6 CBM 2011-01-23 13:13:09 UTC
Comment 1 is still not looking at the right problem, though. This link fails on the live software on enwiki: 

http://en.wikipedia.org/w/index.php?title=User:CBM/Empty&action=edit&section=0
Comment 7 Jarry1250 2011-03-19 22:59:36 UTC
Created attachment 8316 [details]
Patch v1

I think this should be sufficient? It seems to fix the issue for me on my test wiki, anyway. Regards.
Comment 8 Sam Reed (reedy) 2011-03-19 23:24:39 UTC
r84357

Thanks!

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links