Last modified: 2014-09-06 23:29:51 UTC
Should probably be $wgUsersNotifiedOnAllChanges.
Do we want to break compatibility for this?
Maybe support both in 1.13, remove it in 1.14?
Just note that the name was fixed in release notes. People will figure it out. :)
Fixed in r32683.
It wasn't actually misspelled: https://www.mediawiki.org/w/index.php?title=Manual:$wgUsersNotifiedOnAllChanges&diff=507845&oldid=455009