Last modified: 2009-06-01 04:56:28 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 13424 - Use HTML 5 <audio> element instead of <video> for audio files
Use HTML 5 <audio> element instead of <video> for audio files
Status: RESOLVED FIXED
Product: MediaWiki extensions
Classification: Unclassified
OggHandler (Other open bugs)
unspecified
All All
: Normal enhancement (vote)
: ---
Assigned To: Tim Starling
http://commons.wikimedia.org/wiki/Ima...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-18 21:08 UTC by Brion Vibber
Modified: 2009-06-01 04:56 UTC (History)
1 user (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Brion Vibber 2008-03-18 21:08:07 UTC
At least under Safari 3.1, the <video> element seems to like to hide its controls when you're not using them, and is just an invisible rectangle while an audio file is playing.

Did a quick hack test under Safari 3.1; <audio> appears to work correctly just substituting in for <video>, but without hiding the controls, so it's more usable.

Haven't tested with Firefox or Opera builds that support <video>; unsure whether they also support <audio> at this time. May be wise to test support for them separately.
Comment 1 Gregory Maxwell 2009-06-01 04:56:28 UTC
r51265 

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links