Last modified: 2008-12-18 17:45:41 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 13378 - lineStart invoked from {{PAGENAME}} breaks messages
lineStart invoked from {{PAGENAME}} breaks messages
Status: RESOLVED DUPLICATE of bug 12974
Product: MediaWiki
Classification: Unclassified
Parser (Other open bugs)
unspecified
All All
: High major (vote)
: ---
Assigned To: Nobody - You can work on this!
http://meta.wikimedia.org/wiki/*invalid
: patch
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-15 08:02 UTC by metoaster
Modified: 2008-12-18 17:45 UTC (History)
4 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
GlobalFunctions patch (757 bytes, patch)
2008-03-16 10:02 UTC, Nicolas Dumazet
Details

Description metoaster 2008-03-15 08:02:22 UTC
My english isn't good, but i think the link explains itselft...
http://meta.wikimedia.org/wiki/*invalid
also works on every MediaWiki I tested
Comment 1 Roan Kattouw 2008-03-15 13:33:31 UTC
Looks like a parser bug
Comment 2 Huji 2008-03-15 21:15:37 UTC
(In reply to comment #1)
> Looks like a parser bug

Yes, and I've increased the priority and severity of the bug.
Comment 3 Nicolas Dumazet 2008-03-16 10:02:21 UTC
Created attachment 4726 [details]
GlobalFunctions patch

I first noticed that this bug would only occur when using the PAGENAME magicword : The magicwords were escaped, in the Parser, using wfEscapeWikiText(), but * were not being escaped in this function.

Patch included.

Cheers !
Comment 4 Tim Starling 2008-03-16 10:17:52 UTC
Patching wfEscapeWikiText() is certainly the wrong way to fix this problem. Suppression of the lineStart (bug 529) behaviour inside links would be more appropriate, and should be easy to implement.
Comment 5 Mormegil 2008-12-18 17:45:41 UTC
This is another manifestation of the terrible idea implemented in bug 529 and reported in bug 12974, marking as duplicate.

*** This bug has been marked as a duplicate of bug 12974 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links