Last modified: 2010-05-15 15:59:35 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 13068 - Problem with Special:Import
Problem with Special:Import
Status: RESOLVED INVALID
Product: MediaWiki
Classification: Unclassified
Special pages (Other open bugs)
1.11.x
PC Linux
: Low normal (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-19 09:58 UTC by moissinac
Modified: 2010-05-15 15:59 UTC (History)
2 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description moissinac 2008-02-19 09:58:27 UTC
I'm using a new server and migrating my previous Mediawiki (http://shadow.enst.fr/barbules) on this server.
It was common for me to import pages from the Special:Import page.
But on the new installation, it doesn't work. I'm always getting the message:
"L’import du fichier a échoué : il est possible que celui-ci dépasse la taille autorisée.

Veuillez exporter le fichier depuis le wiki d’origine en utilisant l’outil Special:Export, le sauvegarder sur votre disque dur et le copier ici. "

In english something like 'import fails; perhaps too big" when I try to import a really small file (23 Kb) that I'm able to import on my previous wiki.

After walking in the documentation and checking a lot of things  (LocalSettings.php file, rights on my wiki directories...) I'm hoping some help.

- php.ini is correctly set with upload on and post and upload size set to 8M
- all rights have been set to RWX for all the world (just for the purpose of test)

(Note: the new server is not online while this problem is not solved)
Comment 1 Kalan 2008-02-19 10:08:37 UTC
Have you tried to call

php maintenance/importDump.php < /path/to/your/dump/your_dump.xml

from command line?
Comment 2 moissinac 2008-02-19 10:34:58 UTC
With the following command
php maintenance/importDump.php < /home/tux/Barbules-20080219101508.xml

I get the following answer
ALERT - script tried to increase memory_limit to 4294967295 bytes
which is above the allowed value (attacker 'REMOTE_ADDR not set', file
'/opt/lampp/htdocs/barbules/maintenance/commandLine.inc', line 217)
PHP Fatal error:  Call to undefined function xml_parser_create() in
/opt/lampp/htdocs/barbules/includes/SpecialImport.php on line 418

The Barbules-20080219101508.xml file has 2239 bytes.
Comment 3 moissinac 2008-02-22 10:06:01 UTC
I'm working with a Mandriva distribution of Linux
The support for XML seems to be enabled
I don't understand why I get the message
PHP Fatal error:  Call to undefined function xml_parser_create() ...

============================================
My web server environment is a LAMPP distribution with PHP 5.2.5
PHPInfo gives me the following info related to XML
dom
DOM/XML 	enabled
DOM/XML API Version 	20031129
libxml Version 	2.6.11
HTML Support 	enabled
XPath Support 	enabled
XPointer Support 	enabled
Schema Support 	enabled
RelaxNG Support 	enabled

libxml
libXML support 	active
libXML Version 	2.6.11
libXML streams 	enabled

SimpleXML
Simplexml support	enabled
Revision 	$Revision: 1.151.2.22.2.35 $
Schema support 	enabled


XML Support 	active
XML Namespace Support 	active
libxml2 Version 	2.6.11

xmlreader
XMLReader 	enabled

xmlwriter
XMLWriter 	enabled
======================================================

My command line envrionment seems to use a diffrent installation of PHP
PHP version 5.2.4
with the following information extracted from the command line php -i
phpinfo()
PHP Version => 5.2.4
...
/etc/php.d/49_simplexml.ini,
...
/etc/php.d/63_xmlreader.ini,
...
/etc/php.d/64_xmlwriter.ini,
...
dom

DOM/XML => enabled
DOM/XML API Version => 20031129
libxml Version => 2.6.29
...
libxml

libXML support => active
libXML Version => 2.6.29
libXML streams => enabled
...
SimpleXML

Simplexml support => enabled
Revision => $Revision: 1.151.2.22.2.35 $
...
xmlreader

XMLReader => enabled

xmlwriter

XMLWriter => enabled
...


Comment 4 moissinac 2008-02-27 13:52:56 UTC
My server is working with XAMPP
I don't know how to get php working in command line from the XAMPP install.
So, I have worked with a separate install of PHP
After somme problem to hava xml and mysql working with that PHP install,
I know have the command line

php maintenance/importDump.php < /path/to/your/dump/my_dump.xml

working (near from).

I need to call the maintenance/rebuildtextindex.php
to be able to search for the imported pages.
These pages doesn't appears in the 'recent changes' page.
(I have tried the maintenance/rebuildrecentchanges.php command, without success)

BUT THE IMPORT FROM THE WEB INTERFACE ALWAYS FAILS WITH THE SAME MESSAGE
and I can't easily access the the importDump command line each time I have a new page to load.

Has you can see I'm fighting with this problem from the 19/2 and I'm hoping some help.

Thank you in advance
Comment 5 Brion Vibber 2008-02-27 18:13:17 UTC
It sounds like you've got a basic problem with file uploads; confirm that you can upload files (for instance image files) for other purposes.
Comment 6 moissinac 2008-02-28 10:00:37 UTC
Thank you for the advice
It was a problem of owner of the uploaddir of my system
For others who can I have the same problem:
the uploaddir is defined in the php.ini by the line
upload_tmp_dir = /my/path/to/uploaddir
and must be writable by the 'user' which represents the server.




Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links