Last modified: 2005-01-11 09:47:09 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 1292 - foundation website editing broken
foundation website editing broken
Status: RESOLVED FIXED
Product: Wikimedia
Classification: Unclassified
General/Unknown (Other open bugs)
unspecified
All All
: High blocker (vote)
: ---
Assigned To: Nobody - You can work on this!
http://wikimediafoundation.org
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-09 06:02 UTC by Anthere
Modified: 2005-01-11 09:47 UTC (History)
0 users

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Anthere 2005-01-09 06:02:38 UTC
I noticed since early january that the foundation website could not be edited
any more. When one tries to edit, there is a bug basically saying

Database error
The official website of the Wikimedia Foundation
You probably tried a search or other operation which took too long. Possible
reasons include:

    * A search where all words are in quotes. Try searching without the quotes
initially. If that isn't good enough, add a few more words or use a word or two
outside the quotes to indicate the general topic area.
    * An exceptionally large personal watchlist (probably over 10,000 items) at
busy times.
* You may have been unlucky and tried when the database servers were temporarily
exceptionally loaded. When under exceptional load many harmless tasks may be
ended at once to quickly restore normal response times. Try again in five
minutes if you know that what you are doing is normally fine.

The generic error message is:

A database error has occurred. This could be because of an unacceptable search
query (see Searching Wikimedia Foundation), or it may indicate a bug in the
software. The last attempted database query was:
UPDATE cur SET cur_text='',cur_comment='',cur_minor_edit=0,
cur_user=1,cur_timestamp='20050109055749',cur_user_text='Anthere',cur_is_redirect=0,
cur_is_new=0, cur_touched='20050109055749', inverse_timestamp='79949890944250'
WHERE cur_id=460 AND cur_timestamp='20041002223908' from within function
"Article::updateArticle". MySQL returned error "1223: Can't execute the query
because you have a conflicting read lock".

If the error above is 2013 your operation was ended by the database load
manager. Please improve your search or try again at a less busy time. Sorry for
the inconvenience. 
------

Hope it is not too long :-)
Comment 1 Angela 2005-01-10 19:53:02 UTC
The same thing happens on the grants wiki at http://grants.wikimedia.org/
Comment 2 Brion Vibber 2005-01-11 09:47:09 UTC
Looks like Jamesday forgot to update the 1.3 wiki configuration, so the 
remaining few were stuck trying to write to the old database, now locked.

Have fixed up the config and it seems to work now.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links