Last modified: 2008-02-07 12:42:54 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 12565 - CreateMessageIndex.php throws an error message
CreateMessageIndex.php throws an error message
Status: RESOLVED FIXED
Product: MediaWiki extensions
Classification: Unclassified
Translate (Other open bugs)
unspecified
All All
: Normal enhancement (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-09 16:33 UTC by Huji
Modified: 2008-02-07 12:42 UTC (History)
1 user (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
The full output of running php CreateMessageIndex.php (4.05 KB, text/plain)
2008-01-09 16:33 UTC, Huji
Details

Description Huji 2008-01-09 16:33:12 UTC
Created attachment 4524 [details]
The full output of running    php CreateMessageIndex.php

Here is the erorr message

Warning: Invalid argument supplied for foreach() in D:\SVN\phase3\extensions\Translate\CreateMessageIndex.php on line 18

I've attached the full output too.
Comment 1 Niklas Laxström 2008-01-17 12:28:01 UTC
You want to disable freecol group, because the files it need are not in mediawiki svn and need some effort to set up. Of course the code should not throw warnings. 
Comment 2 Huji 2008-01-31 10:28:58 UTC
Alternatively, you might want to remove the FreeCol group from the SVN code (which is supposed to be working on every machine) and only add it on Betawiki?
Comment 3 Niklas Laxström 2008-01-31 12:11:23 UTC
I disagree. It's a configuration issue. Additionally, it should throw errors anymore.
Comment 4 Huji 2008-01-31 12:37:58 UTC
I'm sorry Niklas, but I'm reopening this bug, because no good solution is provided. Even if this is a configuration issue, the "default" config (to be used by people who make a clean install of MediaWiki and add Translate extension) should be in a way that no error message is given.

I tried it just now. Installed a clean wiki, installed Translate extension on it, and ran CreateMessageIndex.php and the error message is still there. Please mark this bug as fixed as soon as the default behaviour of the translation is changed.
Comment 5 Huji 2008-02-07 12:42:54 UTC
It is fixed since r30350. Thank you :)

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links