Last modified: 2007-12-25 10:37:42 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 12407 - MediaWiki:Comma-separator should be &#x20 (or &#32) instead of &#20
MediaWiki:Comma-separator should be &#x20 (or &#32) instead of &#20
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
Internationalization (Other open bugs)
1.12.x
All All
: Normal minor (vote)
: ---
Assigned To: Nobody - You can work on this!
: patch
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-24 22:00 UTC by Lejonel
Modified: 2007-12-25 10:37 UTC (History)
1 user (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
patch to change #20 to #x20 in 'comma-separator' (717 bytes, patch)
2007-12-24 22:00 UTC, Lejonel
Details

Description Lejonel 2007-12-24 22:00:39 UTC
Created attachment 4465 [details]
patch to change #20 to #x20 in 'comma-separator'

The message 'comma-separator' in the English message file is supposed to be a comma and a white-space. Currently the message is ',', but whitespace is #x20 (using hexadecimal) or #32 (using decimal), not #20. So the message should be changed to ', ' or ', '.
Comment 1 Victor Vasiliev 2007-12-25 07:41:40 UTC
That's what have already been done in r28735.
Comment 2 Lejonel 2007-12-25 10:16:26 UTC
No, I think r28735 was supposed to add ' ', but there was a mistake and '' (without the x) is used.  is a control character and is not displayed as a whitespace. The bug can be seen in the list of filetypes at Special:Upload. 
Comment 3 Victor Vasiliev 2007-12-25 10:37:42 UTC
Oh, I see. I've also seen it yesterday and thought I committed the fix :) Fixed in r28836

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links