Last modified: 2005-01-30 04:14:23 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 1228 - HTML-escaped characters in enclosed URL links are double escaped
HTML-escaped characters in enclosed URL links are double escaped
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
General/Unknown (Other open bugs)
unspecified
All All
: Normal normal (vote)
: ---
Assigned To: Nobody - You can work on this!
http://meta.wikimedia.org/wiki/Sandbo...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-29 19:55 UTC by PS
Modified: 2005-01-30 04:14 UTC (History)
0 users

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description PS 2004-12-29 19:55:51 UTC
Links on a current Wikipedia ArbCom page such as:

OLD LINKS, USED TO WORK, NOW FAILS:
http://en.wikipedia.org/w/wiki.phtml?
title=Talk:Zoophilia&diff=6946799&oldid=6946719

http://en.wikipedia.org/w/wiki.phtml?
title=Special:Contributions&hideminor=0&target=24.61.31.36&lim
it=1000&offset=0


CURRENT LINKS, WORK CORRECTLY:
http://en.wikipedia.org/w/wiki.phtml?
title=Talk:Zoophilia&diff=6946799&oldid=6946719

http://en.wikipedia.org/w/index.php?
title=Special:Contributions&hideminor=0&namespace=&target=24.61.31.36&limi
t=2000&offset=0

which worked up until recently, now do not work. Replacement of & by 
& fixes it.  Whilst it makes sense as a fix, this also breaks many old 
links which now will not succeed. Probably due to upgrade to 1.4 fork.

Solutions?

1) Send a bot out to convert all relevant links with & in the URL to 
the correct character

2) re-modify the mediawiki code to allow the old (less correct) form.
Comment 1 Antoine "hashar" Musso (WMF) 2005-01-17 18:40:35 UTC
I believe the "&" was a bug. Probably dont want to reimplement it :(
Comment 2 PS 2005-01-17 18:53:01 UTC
That makes sense.  The problem is, there are now links within WP that used it and 
now no longer work.

Since it almost certainly was unintended, and it is quite sensible to remove the 
behaviour, perhaps a bot that goes through WP cur and history, and replaces internal 
links containing "&" with "&", would be a good way to fix that problem?
Comment 3 Brion Vibber 2005-01-29 07:59:44 UTC
The links with & in the original text work as expected when inserted directly in 
text, but get double-escaped in [http:...] enclosed links. This was probably caused by 
an incorrect fix for completely unescaped links.
Comment 4 Brion Vibber 2005-01-30 04:14:23 UTC
Bug now fixed. Affected pages should be ?action=purge'd to rebuild parser cache.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links