Last modified: 2008-03-11 17:29:49 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 12004 - categories that should be populated by templates using parser functions remain empty more often than not
categories that should be populated by templates using parser functions remai...
Status: RESOLVED DUPLICATE of bug 5382
Product: MediaWiki
Classification: Unclassified
Templates (Other open bugs)
unspecified
All All
: Normal normal with 1 vote (vote)
: ---
Assigned To: Nobody - You can work on this!
http://en.wikipedia.org/wiki/Category...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-16 19:33 UTC by esprit15d
Modified: 2008-03-11 17:29 UTC (History)
1 user (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description esprit15d 2007-11-16 19:33:16 UTC
#Go to en.wikipedia
#Go to Category:Proposed deletion, and then click on the current day.
#Find an article with a proposed deletion tag (the prod tag should have red text)
#Notice at the bottom of the page Categories: Expired proposed deletion.  Click on the category.
#Notice that the category is empty, or pretty close.
#Now go to Template:Dated prod.  The template contains a parser function that places articles with expired prod tags in the category.  But it half works all the time, and fully works once in a blue moon.
#Then - fix the bug!

I already took this matter to the wikipedia help desk and had the following conversation:
<pre>
I added <nowiki><includeonly>[[Category:Expired proposed deletion]]</includeonly></nowiki> to the {{tl|dated prod}} template.  It was in a parser function that displays a red expired message when the 5-day prod time limit is up.  The template seems to work correctly, and articles with expired prod tags show the message and include the Category.  For example: this article: [[CEXL]].  However, when you click on [[:Category:Expired proposed deletion]] the category is empty.  Only once on the day before yesterday did I see it populated with like 20 articles.  I can't fathom why that is happening.  Help!--Esprit15d<big>([[Wikipedia:Requests_for_adminship/Esprit15d|۝]] • [[User_talk:Esprit15d |۞]] • [[Special:Contributions/Esprit15d|▲]]</big>) 13:30, 9 November 2007 (UTC)
:'''Additional note:''' well today I did see it populated with some cats, so I don't know if it's suddenly working now or not?--Esprit15d<big>([[Wikipedia:Requests_for_adminship/Esprit15d|۝]] • [[User_talk:Esprit15d |۞]] • [[Special:Contributions/Esprit15d|▲]]</big>) 13:38, 9 November 2007 (UTC)
::I had the same problem with the changes I made to {{tl|fair use reduced}}, to categorize into [[CAT:FURD7]].  Basically, dynamic categorization doesn't work reliably in the current software, but a null edit on the template will fix it (though it's difficult with this one, as it's protected).  Also, it may take a couple of hours to fully populate the category. --[[User:Pekaje|Pekaje]] 19:45, 9 November 2007 (UTC)
:::Woah! That null edit thing worked, inexplicably.  I'm an admin, so I was able to edit it.  Thanks!--Esprit15d<big> ([[Wikipedia:Requests_for_adminship/Esprit15d|۝]] • [[User_talk:Esprit15d |۞]] • [[Special:Contributions/Esprit15d|▲]]</big>) 01:35, 11 November 2007 (UTC)
</pre>

Well, it doesn't work anymore - I've null edited that template several times since to no avail.  I also tried null editing articles with the category, and it actually did place them in the category, but, obviously that is ten kinds of pointless.
Comment 1 Aryeh Gregor (not reading bugmail, please e-mail directly) 2008-03-11 17:29:49 UTC

*** This bug has been marked as a duplicate of bug 5382 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links