Last modified: 2009-07-26 02:18:45 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 11958 - 0 as a one character article name causing 'bad title'
0 as a one character article name causing 'bad title'
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
General/Unknown (Other open bugs)
unspecified
All All
: Normal normal (vote)
: ---
Assigned To: Nobody - You can work on this!
http://en.wikipedia.org/wiki/Template:0
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-13 02:53 UTC by Foxhill
Modified: 2009-07-26 02:18 UTC (History)
3 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Foxhill 2007-11-13 02:53:21 UTC
Affecting at least the English and German wikipedia. 

Conversation from the en Village Pump as below -
[http://en.wikipedia.org/wiki/Wikipedia:Village_pump_%28technical%29#Template:0]

==Template:0==
The above template seems to have either disappeared or (according to the page it now [http://en.wikipedia.org/wiki/Template:0 aims at]) is suddenly a bad title. This was/is a spacing template that was used on thousands of articles when right aligning numbers in columns in infoboxes. Is there a reason for this suddenly disappearing/not working that anyone knows of? Is there a replacement? [[User:86.21.74.40|86.21.74.40]] 02:16, 13 November 2007 (UTC)
:This has also happened to the mainspace http://en.wikipedia.org/wiki/0. [[Template:0/doc]] still displays. There are also problems in other tested languages http://de.wikipedia.org/wiki/Vorlage:0 (German template) doesn't work but the article http://de.wikipedia.org/wiki/0 works. I write full URL's because wikilinks to pages called 0 are also misbehaving. For example, the wikilink [[0]] gives the URL http://en.wikipedia.org/wiki/ which goes to the main page. [[User:PrimeHunter|PrimeHunter]] 02:39, 13 November 2007 (UTC)
Comment 1 Eric Burnett 2007-11-13 03:46:17 UTC
The error was caused by svn revision 27443 - ($str == "") was changed to empty($str), which returns true on "0".

The developers should be reverting it as we speak.
Comment 2 Aaron Schulz 2007-11-13 03:48:29 UTC
Fixed in r27448.
Comment 3 p858snake 2009-07-26 02:18:45 UTC
Changing Product: Wikimedia → Mediawiki
Changing Component: WikiBugs → General/Unknown
Reason: The wikibugs component is designed for the I.R.C. bot.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links