Last modified: 2008-08-28 16:32:16 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 11884 - Commons EXIF extractor does not handle "flash"
Commons EXIF extractor does not handle "flash"
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
Uploading (Other open bugs)
1.12.x
All All
: Low minor (vote)
: ---
Assigned To: Antoine "hashar" Musso (WMF)
http://commons.wikimedia.org/wiki/Ima...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-06 04:26 UTC by Dan Jacobson
Modified: 2008-08-28 16:32 UTC (History)
1 user (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Dan Jacobson 2007-11-06 04:26:50 UTC
You say
 Flash 16
when the Debian exif pacakge says
 Flash|Flash did not fire, compulsory flash mode.
for better or worse.
The Debian jhead pacakge says
 Flash used   : No
which I swear is the truth, as I like to have flash turned off.

Anyway, the commons EXIF extractor is wrong.
Comment 1 Antoine "hashar" Musso (WMF) 2008-08-27 19:12:58 UTC
Flash is not handled by our EXIF implementation.
16d is 0x10 which mean "Flash did not fire, compulsory flash mode" 

http://exif.org/Exif2-2.PDF pages 42
Comment 2 Antoine "hashar" Musso (WMF) 2008-08-28 16:32:16 UTC
Implemented with r40164.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links