Last modified: 2008-04-27 00:20:20 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 11368 - When I click cur, diff and last on history and Recent Changes, it asks me if I want to download something.
When I click cur, diff and last on history and Recent Changes, it asks me if ...
Status: RESOLVED WORKSFORME
Product: Wikimedia
Classification: Unclassified
General/Unknown (Other open bugs)
unspecified
All All
: Normal normal (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-16 23:05 UTC by Kevinwongii
Modified: 2008-04-27 00:20 UTC (History)
2 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
Screenshot of file download prompt. (114.54 KB, image/jpeg)
2007-09-17 10:46 UTC, Ian Dudley
Details
Binary file downloaded (12.63 KB, application/octet-stream)
2007-09-17 10:49 UTC, Ian Dudley
Details

Description Kevinwongii 2007-09-16 23:05:24 UTC
 
Comment 1 Casey Brown 2007-09-17 00:09:27 UTC
This is most likely a browser problem.  I assume that your browser is somehow set so that "Save Link As" is the default as opposed to "Open link".  This does not seem to be a software problem.
Comment 2 Rob Church 2007-09-17 00:09:37 UTC
What site? What download? More details, please! Do you have "external diff" switched on in your preferences?
Comment 3 Rob Church 2007-09-17 00:10:12 UTC
(Reopening until we've definitely confirmed it's not our end for some reason...)
Comment 4 Ian Dudley 2007-09-17 10:38:37 UTC
I've found this entry while searching for a problem I've just encountered. Not sure if it's the same issue, but it sounds similar.

I've recently done a substantial update to the wikipedia page for the rock band 'Love/Hate' (http://en.wikipedia.org/wiki/Love/Hate). When I tried to go to the page today, I get a file download prompt for a file called 'hate' with no extension. The resilt is a 12k binary file that I can't decypher. 

I'm guessing that the problem is related to there being a forward slash in the page title. I didn't create the page this way, I simply edited the existing page. However, I've had no problem up until now, it's only today that I suddenly can't access the page. Also, looking at the page for the band 'AC/DC' (http://en.wikipedia.org/wiki/AC/DC) which has exactly the same title structure for the same reason, works fine.

I am using the same browser installation (IE 6.0.2900.2180.xpsp_sp2_gdr.070227-2254) on the same laptop as all previous times I've accessed. I am at work today using the connection here, whereas over the weekend I was connecting from home. But I also connected from work last week without problem and I'm not aware of any changes to the technical environment (I'm Head of IT here so I would hope someone would tell me!). I can confirm that my browser defintely isn't set to use 'save link as' by default. I've also tried right clicking the link and using 'open' or 'open in a new browser' to confirm there is nothing like that going on.

I can't access the page at all, so I'm not even able to edit the page title. Very weird. I have this page on my watchlist, and acording to that no-one has edited it since I last made an update (username 'ThePaintedOne') and it was certainly working for me after I made that update.

I'll check when I get home to see if a different internet connection makes any difference to this.
Comment 5 Ian Dudley 2007-09-17 10:46:22 UTC
Created attachment 4119 [details]
Screenshot of file download prompt.

Don't know if it helps, but this is a screenshot of the file download prompt after I clicked on the 'Love/Hate' link visible on my watchlist. I've tried other methods of getting to the page with the same result, so its not the watchlist in error.
Comment 6 Ian Dudley 2007-09-17 10:49:08 UTC
Created attachment 4120 [details]
Binary file downloaded

This is the file that is downloaded if I accept the prompt. Nothing further occurs and the page is not displayed.
Comment 7 Brion Vibber 2007-09-17 14:20:46 UTC
Looks ok here... maybe just a borked header in a cache.
Comment 8 Ian Dudley 2007-09-17 14:38:39 UTC
Hmm, weird. It was knackered for hours this morning, but seems fine again now. 

thanks for the check.
Comment 9 Kevinwongii 2007-09-19 03:36:09 UTC
(In reply to comment #2)
> What site? What download? More details, please! Do you have "external diff"
> switched on in your preferences?

Well, it says the file to be downloaded is "index.php". It dosen't happen when I do it as an anon. ~~~~
Comment 10 Brion Vibber 2008-04-27 00:20:20 UTC
Hoping problem was mysterious and transitory. Possible old problems with bad cache headers.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links