Last modified: 2010-05-15 15:59:38 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 11293 - page editing does not work
page editing does not work
Status: RESOLVED INVALID
Product: MediaWiki
Classification: Unclassified
General/Unknown (Other open bugs)
1.11.x
All All
: Normal critical (vote)
: ---
Assigned To: Nobody - You can work on this!
http://www.terrapedia.org
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-11 19:13 UTC by DarsVaeda
Modified: 2010-05-15 15:59 UTC (History)
2 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description DarsVaeda 2007-09-11 19:13:27 UTC
hi,

editing a page ends alawys in editing "Index.php".
has something to do with short urls.
i have set up
"www.url.org/Main_Page" short url type
it worked with 1.10
if i set up normal urls editing works in 1.11 too

my htaccess is:
RewriteEngine On
RewriteCond %{HTTP_REFERER}
RewriteRule .* %{HTTP_REFERER} [R,L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^(.+)$ /index.php/$1 [L]

LocalSettings.php is:
$wgScriptPath = "";
$wgArticlePath = "/$1";

i can post any additional information that may help.
Comment 1 Platonides 2007-09-11 19:40:42 UTC
Not a Mediawiki bug.
You need to skip the rewriting if the file exists (index.php).

You can edit with http://www.terrapedia.org/Hauptseite?action=edit
Comment 2 DarsVaeda 2007-09-12 11:54:00 UTC
are you sure it is a mod_rewrite problem?
because it worked as expected within 1.10 but with 1.11 not.
the link to the edit page is as expected also the url is when you click it:
http://www.terrapedia.org/index.php?title=Hauptseite&action=edit

but it just ends in editing index.php.

i'm just confused because it worked before without any problems!
Comment 3 Daniel Kinzler 2007-09-12 13:52:55 UTC
It is a mod rewrite problem. As the manual says: DO NOT MAP WIKI PAGES TO THE DOCUMENT ROOT. Read all the big fat warning boxes on http://www.mediawiki.org/wiki/Manual:Short_URLs

This rule is the problem: RewriteRule ^(.+)$ /index.php/$1 [L]
If you request /index.php?title=Foo&action=edit, the rule will match, and it will be rewritten to /index.php?title=index.php&action=edit
Same goes for loading the css and js files mediawiki needs.

Basically, go with the standard "files in /w, pages in /wiki" setup. Or be very carefull to get the setup right, and expect more problems in the future. 
Comment 4 DarsVaeda 2007-09-12 14:00:30 UTC
ok but i still don't get why its working in 1.10 then?!
is that making sense?
because the rewrite would be the same and should not work.
but it does?

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links