Last modified: 2013-09-04 13:04:52 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 11198 - MediaWiki forgets you're logged in when using LDAP Authentication and $wgCookieSecure=true
MediaWiki forgets you're logged in when using LDAP Authentication and $wgCook...
Status: NEW
Product: MediaWiki
Classification: Unclassified
User login and signup (Other open bugs)
1.10.x
All All
: Low normal with 1 vote (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-05 16:57 UTC by Ryan Fuerst
Modified: 2013-09-04 13:04 UTC (History)
5 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Ryan Fuerst 2007-09-05 16:57:05 UTC
I have an install of media wiki 1.9.3 which I upgraded to 1.10.1 (then tried the alpha version) on upgrading when I login it says Im logged in, but when I click the main page. The main page says I am not logged in and I need to login.  When I click the login link it takes me to the login which shows that I am logged in.  I don't actually get logged in everywhere unless I click on the preferences option in the upper right, then login using the link it gives me.  Once I login in that method everything works fine.

This starts happening once i upgraded from 1.9.3 to 1.10.1.  If I downgrade to 1.9.3 it goes away.

I tried various browsers, happens in all of them.  Once you login though successfully you stop encountering the problem, unless you clear your cache and restart.
Comment 1 Tim Chambers 2007-09-05 19:09:12 UTC
Ryan and I are on the same team. He didn't mention that the problem manifests itself only with the LDAP plugin: http://www.mediawiki.org/wiki/Extension:LDAP_Authentication

Another symptom: it seems to be related to the _session cookie. We noticed that the session cookie value is changed when we log in through the preferences page, and that's what cleans up the problem. Once successfully logged in, users don't seem to have the problem again.

I turned on debugging and looked at the logs, but I couldn't find a clue.
Comment 2 Ryan Lane 2008-08-18 03:34:09 UTC
Are you using the LDAP plugin for auto-authentication (like $wgLDAPUseSSLAuth), or just for normal password authentication?

Newer versions of MediaWiki aren't working with the auto-authentication part of the plugin. Let me know if this is the case, and I'll try to check out the issue for you.

Btw, if you are having issues with the LDAP plugin, you should post your issues on the talk page of the plugin on mediawiki.org. I don't check bugzilla for issues very often.
Comment 3 Ryan Fuerst 2008-08-18 16:28:51 UTC
After digging further I actually managed to fix this by changing the below value from it's default to

$wgCookieSecure = false;

with ldap you log in over a secure session, which creates a secure cookie, which for some reason can only
be read by about half the pages.  So on any page that can't read that cookie your not logged in.

No clue if this is the correct behavior or not, but if it is, you can probable close this. 
Comment 4 Thehelpfulone 2012-05-05 11:36:01 UTC
No comments for just under 4 years - has this been fixed now?
Comment 5 Andre Klapper 2013-09-04 12:29:43 UTC
Ryan Fuerst / Tim Chambers: Is this still a problem in a recent version of MediaWiki (1.19 or later)?

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links