Last modified: 2007-09-10 07:07:47 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 11078 - Disable CAPTCHA for bot flagged accounts
Disable CAPTCHA for bot flagged accounts
Status: RESOLVED WORKSFORME
Product: MediaWiki
Classification: Unclassified
Page editing (Other open bugs)
unspecified
All All
: Normal enhancement (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-27 06:13 UTC by Matt
Modified: 2007-09-10 07:07 UTC (History)
3 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Matt 2007-08-27 06:13:02 UTC
On several wiki's I have to run bots under my own account (especially if they are urgent) as they are constantly asked for a CAPTCHA on introducing new external links. Would it be possible to exempt bot flagged accounts from requiring this?

If it is already possible but not enabled, could this bug be changed to enable bots skipping CAPTCHAs on enwikinews?

Thanks!
Comment 1 Aaron Schulz 2007-08-27 06:30:07 UTC
By default, registered bots can skip captchas. Not sure why you are being prompted.
Comment 2 Brion Vibber 2007-08-27 18:44:24 UTC
It'll help to investigate if we know which account you're having trouble with.
Comment 3 Matt 2007-08-28 05:00:26 UTC
[[User:IdeaBot]] on en wikinews. It was temporarily bot flagged (now unflagged as consensus to flag not yet reached, I can possibly get reflagged for more testing if required), and that did not affect the CAPTCHAs at all. Maybe its enabled for enwikinews?
Comment 4 Brion Vibber 2007-08-28 15:13:54 UTC
It should work, and works in my local testing.
Comment 5 Matt 2007-08-29 01:51:55 UTC
Hmmm... could it be a configuration issue?
Comment 6 Andrew Garrett 2007-09-10 07:07:47 UTC
Has worked in testing - no reason has been given to believe that it doesn't work. Closing as WFM for now.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links