Last modified: 2011-11-29 03:20:58 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 11071 - Downloading Chess.pdf does not work
Downloading Chess.pdf does not work
Status: RESOLVED FIXED
Product: Datasets
Classification: Unclassified
General/Unknown (Other open bugs)
unspecified
PC Windows XP
: Normal normal (vote)
: ---
Assigned To: Brion Vibber
http://upload.wikimedia.org/wikibooks...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-26 18:43 UTC by David Ritchie
Modified: 2011-11-29 03:20 UTC (History)
2 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description David Ritchie 2007-08-26 18:43:32 UTC
I tried clicking the link to download http://upload.wikimedia.org/wikibooks/en/e/e4/Chess.pdf
and I got a blank tab and no network activity.  This happened using Firefox 2.0.0.6, IE 7.0.5730.11 and Opera 9.23.  I have Adobe Reader 7.0 installed.  I tried to download another PDF (lucid_dreaming.pdf) and it worked fine.
Comment 1 Brion Vibber 2007-08-28 00:00:41 UTC
Working for me on XP with Adobe Reader 8.1. Probably a temporary problem.
Comment 2 Daniel Kinzler 2007-08-28 00:26:20 UTC
Reopening: I'm also getting an empty file. At the very least, there's something bad stuck in the chache somewhere.

wget transcript:

> wget -S -O - http://upload.wikimedia.org/wikibooks/en/e/e4/Chess.pdf
--02:23:45--  http://upload.wikimedia.org/wikibooks/en/e/e4/Chess.pdf
           => `-'
Resolving upload.wikimedia.org... 145.97.39.156
Connecting to upload.wikimedia.org|145.97.39.156|:80... connected.
HTTP request sent, awaiting response...
  HTTP/1.0 200 OK
  Content-Type: application/pdf
  ETag: "5248928888418332484"
  Accept-Ranges: bytes
  Last-Modified: Wed, 19 Jul 2006 00:30:25 GMT
  Content-Length: 0
  Date: Sun, 15 Apr 2007 23:27:15 GMT
  Server: lighttpd/1.4.13
  X-Cache: MISS from sq1.wikimedia.org
  X-Cache-Lookup: MISS from sq1.wikimedia.org:3128
  Age: 478307
  X-Cache: HIT from knsq9.knams.wikimedia.org
  X-Cache-Lookup: HIT from knsq9.knams.wikimedia.org:3128
  X-Cache: MISS from knsq9.knams.wikimedia.org
  X-Cache-Lookup: MISS from knsq9.knams.wikimedia.org:80
  Via: 1.0 sq1.wikimedia.org:3128 (squid/2.6.STABLE12), 1.0 knsq9.knams.wikimedia.org:3128 (squid/2.6.STABLE12), 1.0 knsq9.knams.wikimedia.org:80 (squid/2.6.STABLE12)
  Connection: keep-alive
Length: 0 [application/pdf]

    [ <=>                                                                                              ] 0             --.--K/s

02:23:45 (0.00 B/s) - `-' saved [0/0]
Comment 3 Brion Vibber 2007-08-28 15:04:24 UTC
It's stuck in KNAMS cache; can confirm w/:

$ http_proxy=http://upload.knams.wikimedia.org:80 wget -S -O - http://upload.wikimedia.org/wikibooks/en/e/e4/Chess.pdf

A simple ?action=purge on the image page clears it right up.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links