Last modified: 2010-05-15 15:48:24 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 10903 - fragments / anchors in redirect links do not work
fragments / anchors in redirect links do not work
Status: RESOLVED WORKSFORME
Product: MediaWiki
Classification: Unclassified
Redirects (Other open bugs)
1.9.x
All All
: Normal enhancement (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-13 08:40 UTC by Dominik Hamann
Modified: 2010-05-15 15:48 UTC (History)
0 users

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Dominik Hamann 2007-08-13 08:40:16 UTC
Scenario:
The page 'Test' should redirect to 'Bar#baz', i.e. go to 'Bar' and
jump to the anchor 'baz' (e.g. == baz == exists).
So 'Test' looks like this:

  #REDIRECT [[Bar#baz]]

The result: Going to 'Test' redirects to

  Test##baz

which does not jump to #baz. Expected is

  Bar#baz or maybe
  Test#baz
Comment 1 Raimond Spekking 2007-08-13 08:45:10 UTC
This feature was introduced with MW 1.10. I suggest to upgrade.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links