Last modified: 2007-08-19 09:27:15 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 10746 - descriptive text for Special:Attributes is misleading
descriptive text for Special:Attributes is misleading
Status: RESOLVED FIXED
Product: MediaWiki extensions
Classification: Unclassified
Semantic MediaWiki (Other open bugs)
unspecified
All All
: Normal normal (vote)
: ---
Assigned To: Markus Krötzsch
http://ontoworld.org/wiki/Special:Att...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-29 23:02 UTC by S Page
Modified: 2007-08-19 09:27 UTC (History)
0 users

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description S Page 2007-07-29 23:02:36 UTC
The text in Special:Attributes is misleading, it says:
    The following attributes exist in the wiki.

but that's not true.  If there are problems with an attribute page, or the pages using an attribute, then an attribute won't show up in Special:Attributes, even though the attribute has a page and appears in Special:Pages.  This confuses users.

Better, more accurate text is:
    The wiki has pages using the following attributes.

The same is true for Special:Relations (though relations cause fewer problems).

Maybe this problem goes away with new properties system!
Comment 1 Markus Krötzsch 2007-08-19 09:27:15 UTC
With the new properties comes a new implementation of the related special pages. Now all properties that are used somewhere (whether or not declared correctly) are shown. Properties that still will not appear are the following:

* Properties that have a property page but are not used on any page (these can be found on another special page for unused properties). This is the same as for categories.
* Properties that have a page that gives a special datatype, but that are used only wrongly throughout the wiki. This means that *all* values that have been given to the property throughout the wiki are invalid under the datatype (e.g. the type expects a number but no number was given). Then nothing can be stored and the property will also appear only as "unused property".

The second case should be reasonably rare and is also reflected by error messages in the factboxes of the respective articles.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links