Last modified: 2010-05-15 15:56:51 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 10728 - <b>Warning</b>: array_key_exists() [<a href='function.array-key-exists'>function.array-key-exists</a>]: The second argument should be either an array or an object in <b>/home/lionline/public_html/wiki/languages/Language.php</b> on line <b>456</b><br />
<b>Warning</b>: array_key_exists() [<a href='function.array-key-exists'>func...
Status: RESOLVED WORKSFORME
Product: MediaWiki
Classification: Unclassified
Installer (Other open bugs)
1.6.x
All Linux
: High major (vote)
: ---
Assigned To: Peter Armenti
http://www.longislandonline.com/wiki/...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-28 06:21 UTC by Peter Armenti
Modified: 2010-05-15 15:56 UTC (History)
2 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Peter Armenti 2007-07-28 06:21:33 UTC
I just installed the wikimedia and I have recieving this message at the top of every page.  I re-installed twice and am receiving the same message..  Does anyone know how to fix this?  Thank you...

<b>Warning</b>:  array_key_exists() [<a href='function.array-key-exists'>function.array-key-exists</a>]: The second argument should be either an array or an object in <b>/home/lionline/public_html/wiki/languages/Language.php</b> on line <b>456</b><br />
Comment 1 Rob Church 2007-07-28 07:08:23 UTC
MediaWiki 1.6.1 is ancient, upgrade to the 1.10 series and let us know if the bug persists.
Comment 2 Peter Armenti 2007-07-28 07:18:04 UTC
hmmm... I can't... my server and other scripts running on my site don't have support for php5..  so I am stuck with 1.6.1 for now until the rest of the world catches up with php5.  No support for now?
Comment 3 Shinjiman 2007-07-28 07:47:42 UTC
How about the MediaWiki 1.6.10? Can you install that version which does not require the PHP 5?
Comment 4 Chad H. 2009-07-24 14:25:55 UTC
Changing to WFM. Cannot replicate in 1.6 branch. From looking at things, it looks as though you've got a botched 1.6.1 install. Strongly suggest upgrading to 1.6.10 if you _really_ can't use PHP5, or get PHP5 and upgrade to the 1.15.1 release.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links