Last modified: 2010-05-15 15:56:47 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 10604 - Database error causes wiki not to work
Database error causes wiki not to work
Status: RESOLVED INVALID
Product: MediaWiki
Classification: Unclassified
Database (Other open bugs)
1.6.x
All All
: Highest major (vote)
: ---
Assigned To: Nobody - You can work on this!
http://tsf.sonicstrike.net/forums/med...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-16 18:02 UTC by True
Modified: 2010-05-15 15:56 UTC (History)
1 user (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description True 2007-07-16 18:02:50 UTC
I just installed Mediawiki yesterday and it was working fine.. then the next day it keeps displaying this message


A database error has occurred
Query: SELECT user_name,user_password,user_newpassword,user_email,user_email_authenticated,user_real_name,user_options,user_touched,user_token,user_registration FROM `user` WHERE user_id = '1' LIMIT 1
Function: User::loadFromDatabase
Error: 1017 Can't find file: 'user.MYI' (errno: 2) (localhost)

Backtrace:

    * GlobalFunctions.php line 602 calls wfBacktrace()
    * Database.php line 473 calls wfDebugDieBacktrace()
    * Database.php line 419 calls Database::reportQueryError()
    * Database.php line 806 calls Database::query()
    * Database.php line 825 calls Database::select()
    * User.php line 720 calls Database::selectRow()
    * User.php line 667 calls User::loadFromDatabase()
    * Setup.php line 229 calls User::loadFromSession()
    * index.php line 80 calls require_once()



What causes this? Will it ever work again?
Comment 1 Aryeh Gregor (not reading bugmail, please e-mail directly) 2007-07-16 18:06:46 UTC
Your "user" table file has disappeared (possibly along with others).  Dropping the database and reinstalling the software will fix it, but you've lost at the very least your user table.  This has nothing to do with MediaWiki.  Contact your host to discuss why this might have happened on your server and whether the table can be recovered.
Comment 2 Brion Vibber 2007-07-16 18:49:59 UTC
This usually means your database server has accidentally disabled InnoDB tables during an upgrade, or didn't properly copy the InnoDB table space when moving servers.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links