Last modified: 2009-01-21 20:43:34 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 10569 - Special:Mypage and Special:Mytalk cause redirect loops when their targets redirect back
Special:Mypage and Special:Mytalk cause redirect loops when their targets red...
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
Redirects (Other open bugs)
unspecified
All All
: Normal minor (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-13 17:45 UTC by ais523
Modified: 2009-01-21 20:43 UTC (History)
2 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description ais523 2007-07-13 17:45:14 UTC
On MediaWiki wikis that allow redirects to Special pages, it's possible to set up a redirect loop. I've tested redirecting my own userpage to [[Special:Mypage]] (on a private wiki); this creates a redirect loop (that was detected by Firefox, which stopped with an error message informing me of it after a while). I suspect redirecting my talkpage to [[Special:Mytalk]] would have had the same effect, although I didn't test this. ([[Special:Random]] doesn't return redirects, and [[Special:RandomRedirect]] puts redirect=no into the URL, so they don't cause problems.)
Comment 1 Aryeh Gregor (not reading bugmail, please e-mail directly) 2007-07-13 18:04:17 UTC
Special page redirects are poorly implemented at present, which is why they aren't enabled on Wikimedia installations.  Also notice the lack of the "redirected from" message.  This should, needless to say, be fixed by reuse of the redirect code for articles so it's all in one place.
Comment 2 Ryan Schmidt 2009-01-21 20:43:34 UTC
fixed in r45973

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links