Last modified: 2012-04-16 09:24:35 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 10484 - Namespace filter doesn't handle input correctly in invert mode
Namespace filter doesn't handle input correctly in invert mode
Status: RESOLVED FIXED
Product: Utilities
Classification: Unclassified
mwdumper (Other open bugs)
unspecified
All All
: Normal normal (vote)
: ---
Assigned To: Brion Vibber
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-06 20:46 UTC by Brion Vibber
Modified: 2012-04-16 09:24 UTC (History)
1 user (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Brion Vibber 2007-07-06 20:46:20 UTC
This doesn't strip out MediaWiki items as expected:

--filter=namespace:!NS_MEDIAWIKI

Workaround for the moment is to add a comma:

--filter=namespace:!,NS_MEDIAWIKI

The NamespaceFilter class doesn't strip the ! when building the list of namespaces to be filtering, so the first item doesn't get correctly interpreted.
Comment 1 Brion Vibber 2007-07-06 22:14:58 UTC
Fixed in r23804.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links