Last modified: 2010-05-15 15:52:02 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 10386 - Class 'Parser' not found on line 2126 GlobalFunctions.php
Class 'Parser' not found on line 2126 GlobalFunctions.php
Status: RESOLVED WORKSFORME
Product: MediaWiki
Classification: Unclassified
General/Unknown (Other open bugs)
1.10.x
PC Linux
: High normal (vote)
: ---
Assigned To: Nobody - You can work on this!
http://www.larfed.com/wiki/index.php
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-27 15:34 UTC by SMID
Modified: 2010-05-15 15:52 UTC (History)
0 users

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description SMID 2007-06-27 15:34:47 UTC
I've been trying to install MediaWiki, working my way through GoDaddy's PHP 4/5 errors and the tables.sql error with the too many characters stuff, and finally got the wiki installed. During the install, however, I got this same error. I refreshed the page, to see what would happen, and it installed without any more problems. I moved the php file it made after the install, then ran the wiki, and it gave me this error again.

Problem is, I can't find anything on here or on Google that has anything to do with this error, and I know next-to-nothing about this kind of thing, I've been learning as I went along.

I redownloaded the wiki software and copied the new GlobalFunctions.php over the one that's giving the error, but as you can see, nothing changed. I tried to check someone else's GlobalFunctions.php, but there is no line 2126 in theirs, the file ends around line 2020.

So, any help would be greatly appreciated. I don't know what to attach, as I don't imagine attaching my GlobalFunctions would be much help, considering it's identical to the one in the 1.10.0 install file.

Help me, Obi-Wiki Kenobi. You're my only hope.
Comment 1 Aryeh Gregor (not reading bugmail, please e-mail directly) 2007-06-27 17:26:54 UTC
It sounds like the autoloader is malfunctioning.  Are you absolutely certain the file is being executed as PHP5, not PHP4?
Comment 2 SMID 2007-06-27 18:53:03 UTC
Yes. It's a GoDaddy site, so it was having the problem with it launching as PHP4, but I added the .htaccess file last night and corrected that, and it launched fine as a PHP5 file earlier today. Everything ran smoothly until the end of the install, when it gave me the parser error. Then it finished installing fine on the second try, and now it's error-city.
Comment 3 SMID 2007-06-28 05:58:45 UTC
Okay, it must have been a bad file or something. I completely started from scratch, dropped my databases and started over, and did a full re-upload and reinstall, and now it works fine.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links