Last modified: 2007-06-19 22:39:29 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 10313 - "create this page" link in pt-br message file broken
"create this page" link in pt-br message file broken
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
Internationalization (Other open bugs)
1.11.x
All All
: Normal trivial (vote)
: ---
Assigned To: Nobody - You can work on this!
http://computerscience.terapad.com
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-19 17:54 UTC by logan
Modified: 2007-06-19 22:39 UTC (History)
0 users

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description logan 2007-06-19 17:54:09 UTC
Hi. I'm configuring an internal wiki to my company, and I've found a bug: When I change the language to "portuguese"(We're from Brazil) in "my preferences", and I search for a page, if this page don't exist, the "create this page" link disappear. I have no problem to use it in english, but I don't know about the other employees.

Thank's for your attention!


Bruno

PS: The link upthere isn't the link of the wiki. As I said, the company wiki is internal(runs on intranet). It's my Blog(in portuguese) about technology.
Comment 1 Raimond Spekking 2007-06-19 18:13:59 UTC
I assume you changed to 'pt-br'? There is a bug in the messagefile, parameter $1 is missing:

'noexactmatch'          => 'Nenhum artigo com um título exatamente igual a este foi encontrado, tentando na pesquisa completa por texto.',

We can fix this bug if you can give us an appropriate translation.

For help, the 'pt' message is:

'noexactmatch'          => "'''Não existe uma página com o título "$1".''' Você pode [[:\$1|criar tal página]].",
Comment 2 logan 2007-06-19 21:58:13 UTC
(In reply to comment #1)
> I assume you changed to 'pt-br'? There is a bug in the messagefile, parameter
> $1 is missing:
> 
> 'noexactmatch'          => 'Nenhum artigo com um título exatamente igual a
> este foi encontrado, tentando na pesquisa completa por texto.',
> 
> We can fix this bug if you can give us an appropriate translation.
> 
> For help, the 'pt' message is:
> 
> 'noexactmatch'          => "'''Não existe uma página com o título "$1".'''
> Você pode [[:\$1|criar tal página]].",
> 
====================================================================================

Hi Raimond. Yes, I changed the language to 'pt-br'. To fix it, you can keep the same message used in 'pt' language, because in this case, both phrases means the same.

Thank you for the help, and sorry for my terrible english! =P
Comment 3 Aryeh Gregor (not reading bugmail, please e-mail directly) 2007-06-19 22:30:21 UTC
Maybe we should periodically run checkLanguage.php on all the files to ensure no problems like this occur?
Comment 4 Raimond Spekking 2007-06-19 22:39:29 UTC
(In reply to comment #2)
> Hi Raimond. Yes, I changed the language to 'pt-br'. To fix it, you can keep the
> same message used in 'pt' language, because in this case, both phrases means
> the same.

Fixed with r23106.


(In reply to comment #3)
> Maybe we should periodically run checkLanguage.php on all the files to ensure
> no problems like this occur?

This occurs, see [[meta:Localization statistics]]. But if nobody from the devs speak the language it's impossible to fix :-(

A lot of languages are badly maintained :-(


Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links