Last modified: 2007-06-08 01:57:54 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 10194 - Signature gets HTML-escaped
Signature gets HTML-escaped
Status: RESOLVED INVALID
Product: MediaWiki
Classification: Unclassified
User preferences (Other open bugs)
1.10.x
Other Windows XP
: Normal minor (vote)
: ---
Assigned To: Nobody - You can work on this!
http://en.wikipedia.org/wiki/User:Key...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-08 00:46 UTC by Kyle Simmons
Modified: 2007-06-08 01:57 UTC (History)
0 users

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Kyle Simmons 2007-06-08 00:46:30 UTC
I have my signature set to:

[[User:Keylay31|<font color="000000">'''Key'''</font><font color="FFE303">'''lay'''</font>]]

with the Raw signature box unchecked. This normally results in the name Keylay in two colors and a link to my profile. However, when logging in today, upon typing ~~~, the following occurs:

[[User:Keylay31|&#91;&#91;User:Keylay31&#124;&lt;font color=&quot;000000&quot;&gt;&#39;&#39;&#39;Key&#39;&#39;&#39;&lt;/font&gt;&lt;font color=&quot;FFE303&quot;&gt;&#39;&#39;&#39;lay&#39;&#39;&#39;&lt;/font&gt;]]]]

I have provided a link to my sandbox as the URL, you can see the issue there. 

The first thing appearing is the output when I type ~~~, the second when I copy the code in my signature directly to the page, and the output upon entering ~~~~.

Is this an issue with my browser? Or some preference?
Comment 1 Aryeh Gregor (not reading bugmail, please e-mail directly) 2007-06-08 01:57:54 UTC
You're using the feature incorrectly.  Please read the documentation: "If unchecked, the contents of the box above will be treated as your nickname and link automatically to your user page."  You're entering the full link, so it tries putting a link inside a link.  Either check "Raw signature" or use "<font color="000000">'''Key'''</font><font color="FFE303">'''lay'''</font>" instead.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links